- Learn C++ - https://www.learncpp.com -

Tiga 1.0.2 widget fix for WordPress 2.2

This website utilizes the wonderful Tiga 1.0.2 theme, which works great under WordPress 2.1.3. However, when I upgraded the site to WordPress 2.2 (which now has built-in widget functionality), it quickly became clear that the widget functionality was not working properly under the Tiga 1.0.2 theme. Although you can set up your widgets, Tiga 1.0.2 doesn’t realize you’ve changed from the default, and always uses the default set of widgets instead.

After mucking through a bunch of css and php code, I was able to fix the issue. Since Tiga is one of the more popular themes out there, I’m making this solution publicly available.

Download the Tiga 1.0.2 widget fix for WordPress 2.2 [1] *(see note at bottom of post).

Installation is easy. Just copy the sidebar.php file over the existing one in your tiga-06 theme folder.

Happy blogging.

Edit: General WordPress/Tiga questions not specifically related to this fix are best posted in the forum [2], where I am more likely to see them. I am happy to try and answer any questions you may have.

* Important note: I just released a patch [3] for the Tiga theme under WordPress 2.3. It should be backwards compatible with 2.2 as well.